aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-11-18 16:43:08 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-11-18 16:43:08 +0000
commitf2c0ead18c518617a519349f78017bf5454647fc (patch)
tree06d2d5b53ddc7b4aab54d6fc0dd6db99e61b94d1 /configure.ac
parent6f925e459e2ae4342a5120dc896b966d6f232919 (diff)
Change autoconf logic a bit so it says what it is looking for in two instances where it didn't.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@89395 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10865e758..63702a33f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,6 +287,8 @@ AC_FUNC_VPRINTF
AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtol strtoq unsetenv utime vasprintf])
AC_CHECK_FUNCS([glob])
+
+AC_MSG_CHECKING(for timersub in time.h)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <sys/time.h>],
[struct timeval *a; timersub(a, a, a);]),
@@ -308,6 +310,7 @@ AC_CHECK_FUNCS([funopen fopencookie])
AC_CHECK_FUNCS([inet_aton])
# check if we have IP_PKTINFO constant defined
+AC_MSG_CHECKING(for IP_PKTINFO)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <netinet/in.h>],
[int pi = IP_PKTINFO;]),