aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-21 15:31:43 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-21 15:31:43 +0000
commit9e660a37efa3b1f4ab07fe70a37f87477c77fec1 (patch)
tree5e150a471831ab9e7a201a3d85c56e1bb7b2e9b0 /configure.ac
parentdd72dececbf622e72696b075a41f08b5f35ad8a7 (diff)
Merged revisions 241938 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ................ r241938 | seanbright | 2010-01-21 10:27:42 -0500 (Thu, 21 Jan 2010) | 12 lines Merged revisions 241932 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r241932 | seanbright | 2010-01-21 10:25:46 -0500 (Thu, 21 Jan 2010) | 5 lines Fix configure check for PTHREAD_ONCE_INIT when manually adding -Wall to CFLAGS. (closes issue #16666) Reported by: romain_proformatique ........ ................ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.1@241940 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f00751803..3f93cd8eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -479,8 +479,9 @@ saved_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} -Werror -Wmissing-braces"
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [#include <pthread.h>],
- [pthread_once_t once = PTHREAD_ONCE_INIT;])
+ [#include <pthread.h>
+ void empty(){}],
+ [pthread_once_t once = PTHREAD_ONCE_INIT; pthread_once(&once, empty);])
],[
AC_MSG_RESULT(no)
ac_cv_pthread_once_needsbraces="no"