aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2006-09-27 21:48:01 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2006-09-27 21:48:01 +0000
commitc3414d6078b5a1a78ad5e365721c7c8e92436aea (patch)
tree19c66ba038f1893d8d10044cd5ee80620f7260eb /configure.ac
parent8d393950665c407a3c57428475288276783c88d3 (diff)
Add ability to set high ToS bits as non-root on Linux using libcap (issue #7047 reported by maddison)
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@43830 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9337fb8d..e23ab23d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,6 +175,7 @@ AC_SUBST(AST_DEVMODE)
# by the --with option name, to make things easier for the users :-)
AST_EXT_LIB_SETUP([ALSA], [Advanced Linux Sound Architecture], [asound])
+AST_EXT_LIB_SETUP([CAP], [POSIX 1.e capabilities], [cap])
AST_EXT_LIB_SETUP([CURSES], [curses], [curses])
AST_EXT_LIB_SETUP([GNUTLS], [GNU TLS support (used for iksemel only)], [gnutls])
AST_EXT_LIB_SETUP([GSM], [GSM], [gsm], [, or 'internal'])
@@ -330,6 +331,10 @@ AST_EXT_LIB_CHECK([ALSA], [asound], [snd_spcm_init], [alsa/asoundlib.h], [-lm -l
AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
+if test "x${host_os}" = "xlinux-gnu" ; then
+ AST_EXT_LIB_CHECK([CAP], [cap], [cap_from_text], [sys/capability.h])
+fi
+
GSM_INTERNAL="yes"
AC_SUBST(GSM_INTERNAL)
GSM_SYSTEM="yes"