aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2006-07-15 21:39:26 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2006-07-15 21:39:26 +0000
commite63bd04ff0d26d72233e09f24a972d35f752b0fe (patch)
tree05bd9b6d6ee6257d0f444f539cee521b62cfe616 /configure.ac
parentf3b8ad2720ead8b987c52b6bd10087273a1b8e62 (diff)
Move curl version test to autoconf script
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@37678 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 853bdb25f..10dd52275 100644
--- a/configure.ac
+++ b/configure.ac
@@ -879,9 +879,19 @@ PBX_CURL=0
AC_PATH_TOOL([CURL], [curl-config], No)
if test ! x"${CURL}" = xNo; then
# check for version
- CURLLIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ if test $PBX_OSTYPE = "SunOS"; then
+ if [[ 0x`curl-config --vernum` -ge 0x70907 ]]; then
+ CURLLIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
+ else
+ if [[[ 0x`curl-config --vernum` -ge 0x70907 ]]]; then
+ CURLLIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
+ fi
fi
AC_SUBST(PBX_CURL)
AC_SUBST(CURLLIB)