aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormattf <mattf@f38db490-d61c-443f-a65b-d21fe96a405b>2008-05-11 03:23:05 +0000
committermattf <mattf@f38db490-d61c-443f-a65b-d21fe96a405b>2008-05-11 03:23:05 +0000
commit5a8ca0ef8eea9a8dd0ebf2531b13fb579e9a0ffe (patch)
treeef38147193d9186197ce09287d552d5117dd1bbb /configure.ac
parent2fa736cda048c9fa1633b781ece6ed4516f9d0cc (diff)
Add Zap MTP2 support to chan_zap
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@115600 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 15a3f3a44..731197ff8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1290,7 +1290,7 @@ AST_EXT_LIB_CHECK([PORTAUDIO], [portaudio], [Pa_GetDeviceCount], [portaudio.h])
AST_EXT_LIB_CHECK([PRI], [pri], [pri_get_version], [libpri.h])
-AST_EXT_LIB_CHECK([SS7], [ss7], [ss7_get_version], [libss7.h])
+AST_EXT_LIB_CHECK([SS7], [ss7], [ss7_pollflags], [libss7.h])
if test "${USE_PWLIB}" != "no"; then
if test -n "${PWLIB_DIR}"; then
@@ -1485,6 +1485,9 @@ AST_C_DEFINE_CHECK([ZAPTEL_NEONMWI], [ZT_EVENT_NEONMWI_ACTIVE], [zaptel/zaptel.h
# Check for channel alarm support
AST_C_COMPILE_CHECK([ZAPTEL_CHANALARMS], [size_t foo = sizeof(struct zt_params_v1)], [zaptel/zaptel.h])
+# Check for ZT_SIG_MTP2
+AST_C_DEFINE_CHECK([ZAPTEL_SIG_MTP2], [ZT_SIG_MTP2], [zaptel/zaptel.h])
+
# On FreeBSD, try old zaptel (0.80 or so) and pretend we have vldtmf
case "${host_os}" in
freebsd*)