aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-07-07 05:51:29 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-07-07 05:51:29 +0000
commit348045f5a8d61db477fd1bd19ae8c38177aace97 (patch)
tree7609159e04c1ce5a3298ca6d70caf263c080543a /configure.ac
parentabd1f1162b9796d2b5a5183034309b869d4eb56a (diff)
avoid an error from configure by not doing a cat on a file that doesn't exist
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@37284 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 555463d16..853bdb25f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -341,7 +341,9 @@ if test "${USE_IMAP_TK}" != "no"; then
echo -n "checking for UW IMAP Toolkit c-client library... "
saved_cppflags="${CPPFLAGS}"
saved_libs="${LIBS}"
- imap_ldflags=`cat ${IMAP_TK_DIR}/c-client/LDFLAGS`
+ if test -f ${IMAP_TK_DIR}/c-client/LDFLAGS ; then
+ imap_ldflags=`cat ${IMAP_TK_DIR}/c-client/LDFLAGS`
+ fi
CPPFLAGS="${CPPFLAGS} -I${IMAP_TK_DIR}/c-client"
LIBS="${LIBS} ${IMAP_TK_DIR}/c-client/c-client.a "`echo ${imap_ldflags}`
AC_LINK_IFELSE(