aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-07-28 19:53:56 +0000
committermmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-07-28 19:53:56 +0000
commitd1ae07e8e7b4772ea0767357c66a18e2be45b28d (patch)
tree7979e811b4a0d72d680fe0cc2681c8477def34df /configure.ac
parentaa5fc8c25632317394c2afcb46a20323900ad793 (diff)
This commit compensates for buggy poll(2)
implementations. Asterisk has, for a long time, had its own implementation of poll(2) which just used the input arguments to call select(2). In 1.4, this internal implementation was used for Darwin systems. This was removed in Asterisk trunk at some point, but it seems as though this was not the right move to make. On Mac OS X, it appears as though the poll used to gather CLI input does not respond properly when connecting via a remote Asterisk console. Reverting to the use of Asterisk's poll fixed the issue. Also, there is now an option for the configure script, --enable-internal-poll, which will allow for anyone to use Asterisk's internal poll implementation in case they suspect that their system's poll implementation is buggy. closes issue #11928) Reported by: adriavidal Patches: 1.6.0-configurev2.patch uploaded by putnopvut (license 60) git-svn-id: http://svn.digium.com/svn/asterisk/trunk@134125 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0d7c306e5..3715edb56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,8 +327,18 @@ AC_CHECK_HEADER([sys/poll.h],
[HAS_POLL=1]
AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),
)
+
+AC_ARG_ENABLE(internal-poll,
+ [ --enable-internal-poll Use Asterisk's poll implementation],
+ [case "${enableval}" in
+ y|ye|yes) HAS_POLL="";;
+ n|no) HAS_POLL="${HAS_POLL}" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-internal-poll) ;;
+ esac])
AC_SUBST(HAS_POLL)
+
+
# https support (in main/http.c) uses funopen on BSD systems,
# fopencookie on linux
AC_CHECK_FUNCS([funopen fopencookie])