aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-16 20:09:10 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-16 20:09:10 +0000
commitff5e5ef9097c511de5bbd1f861ac2a44fe04bf89 (patch)
tree75b94ae735eb470f9dc230f26cdb58990bd180dc /configure.ac
parentd6b06d2ecf7a547decc99355370805871a795af1 (diff)
check for pre-1.4 versions of Zaptel and abort the configure script if found with an appropriate error message
git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@47758 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eded81a16..881137cb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -952,6 +952,38 @@ if test "${USE_ZAPTEL}" != "no"; then
fi
fi
+if test "${USE_ZAPTEL}" != "no"; then
+ if test "${PBX_ZAPTEL}" != "1"; then
+ AC_MSG_CHECKING(for ZT_DIAL_OP_CANCEL in zaptel.h)
+ saved_cppflags="${CPPFLAGS}"
+ if test "x${ZAPTEL_DIR}" != "x"; then
+ CPPFLAGS="${CPPFLAGS} -I${ZAPTEL_DIR}/include"
+ fi
+ AC_COMPILE_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <zaptel.h>],
+ [int foo = ZT_DIAL_OP_CANCEL;])
+ ],
+ [ AC_MSG_RESULT(yes)
+ ac_cv_zaptel_h="yes"
+ ],
+ [ AC_MSG_RESULT(no)
+ ac_cv_zaptel_h="no"
+ ]
+ )
+ CPPFLAGS="${saved_cppflags}"
+ if test "${ac_cv_zaptel_h}" = "yes"; then
+ AC_MSG_NOTICE(***)
+ AC_MSG_NOTICE(*** The Zaptel installation on this system is too old)
+ AC_MSG_NOTICE(*** to be useable with this version of Asterisk.)
+ AC_MSG_NOTICE(*** Either upgrade your Zaptel installation, or run configure)
+ AC_MSG_NOTICE(*** including --without-zaptel.)
+ exit 1
+ fi
+ fi
+fi
+
EDITLINE_LIB=""
if test "x$TERMCAP_LIB" != "x" ; then
EDITLINE_LIB="$TERMCAP_LIB"