aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-15 23:56:10 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-15 23:56:10 +0000
commitdd1ff847dd05622530e47cbd4bd9a27932717d22 (patch)
tree73a824358ae30b264e8f3b736205f9ae06157001 /configure.ac
parente13cf5101342743aed011861058fb1bbe95ae20e (diff)
Merged revisions 58947 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r58947 | russell | 2007-03-15 18:53:26 -0500 (Thu, 15 Mar 2007) | 3 lines Add configure script checking for GTK2 and some additional Makefile targets to support gmenuselect ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@58948 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 541921be6..fc7e52b79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -981,6 +981,18 @@ AC_SUBST(PBX_GTK)
AC_SUBST(GTK_INCLUDE)
AC_SUBST(GTK_LIB)
+PBX_GTK2=0
+AC_CHECK_TOOL(PKGCONFIG, pkg-config, No)
+if test ! "x${PKGCONFIG}" = xNo; then
+ GTK2_INCLUDE=$(${PKGCONFIG} gtk+-2.0 --cflags)
+ GTK2_LIB=$(${PKGCONFIG} gtk+-2.0 --libs)
+ PBX_GTK2=1
+ AC_DEFINE([HAVE_GTK2], 1, [Define if your system has the GTK2 libraries.])
+fi
+AC_SUBST(PBX_GTK2)
+AC_SUBST(GTK2_INCLUDE)
+AC_SUBST(GTK2_LIB)
+
if test "${USE_CURL}" != "no"; then
AC_PATH_TOOL([CURL_CONFIG], [curl-config], No)
if test ! x"${CURL_CONFIG}" = xNo; then