aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-01 22:35:52 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-01 22:35:52 +0000
commit1675708f88249fa04c6135d8e889791c631109b2 (patch)
tree6edaa2e8ccf73ae403000c1b2bfad93110f65058 /configure.ac
parent6712e666a8c4e4b0fc84f2d04b8975ec9fe6c1a6 (diff)
Merged revisions 46845 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r46845 | russell | 2006-11-01 17:32:12 -0500 (Wed, 01 Nov 2006) | 5 lines Add a check in the configure script to determine whether ld is GNU ld or not. This is needed because module embedding only works for gnu ld. GNU ld is now listed as a dependency for all of the module embedding options in menuselect. (issue #8143) ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@46846 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17f0959ff..d1cf9a09a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,4 @@
+w
# Process this file with autoconf to produce a configure script.
#
# Make sure we use autoconf 2.60 to generate the "configure" script,
@@ -128,12 +129,19 @@ AC_PROG_CC
AC_PROG_CXX
AC_PROG_CPP
AC_PROG_CXXCPP
+AC_PROG_LD
AC_PROG_AWK
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_RANLIB
AST_CHECK_GNU_MAKE
+GNU_LD=0
+if test "x$with_gnu_ld" = "xyes" ; then
+ GNU_LD=1
+fi
+AC_SUBST(GNU_LD)
+
AC_PATH_PROG([GREP], [grep], :)
AC_PATH_PROG([AR], [ar], :)
AC_PATH_PROG([FIND], [find], :)