aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorqwell <qwell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-12-05 20:44:12 +0000
committerqwell <qwell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-12-05 20:44:12 +0000
commitecfc18df4755803de79269c391a5a4d4b25a4ddb (patch)
treef92ad81157396f459be39324f1c7aaf4b7e5fc64 /configure.ac
parentc1729817c56ff3340941d05abf61e30c7d556e88 (diff)
Merged revisions 48279 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r48279 | qwell | 2006-12-05 14:42:52 -0600 (Tue, 05 Dec 2006) | 4 lines Fix curl version number testing to be much more friendly to non-bash shells. Issue 8508, patch by me. This *SHOULD* be POSIX compliant now.. ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@48280 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 7 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index f86d9965b..ac6505a5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -932,22 +932,13 @@ if test "${USE_CURL}" != "no"; then
AC_PATH_TOOL([CURL], [curl-config], No)
if test ! x"${CURL}" = xNo; then
# check for version
- if test "${host_os}" = "SunOS"; then
- if [[ 0x`curl-config --vernum` -ge 0x70907 ]]; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- else
- if [[[ 0x`curl-config --vernum` -ge 0x70907 ]]]; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- fi
- fi
+ if test $(printf "%d" 0x$(curl-config --vernum)) -ge $(printf "%d" 0x070907); then
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
+ fi
fi
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts channels/h323/Makefile])