aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrizzo <rizzo@f38db490-d61c-443f-a65b-d21fe96a405b>2007-01-19 09:39:02 +0000
committerrizzo <rizzo@f38db490-d61c-443f-a65b-d21fe96a405b>2007-01-19 09:39:02 +0000
commit062db24b7c798c600bdb43f7dc720caecb1d1f3b (patch)
tree673d7290cc55b73125da6f60a4b37156bb6bdf89 /configure.ac
parent592f4faecea843134d72a04320331638418a5ef5 (diff)
Add check for backtrace support on platforms that do not have
it natively. Part of it leaked in in a previous commit. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@51287 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40c78d3e5..89dc3345a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,6 +177,9 @@ AC_SUBST(AST_DEVMODE)
# by the --with option name, to make things easier for the users :-)
AST_EXT_LIB_SETUP([ALSA], [Advanced Linux Sound Architecture], [asound])
+
+# BKTR is used for backtrace support on platforms that do not
+# have it natively.
AST_EXT_LIB_SETUP([BKTR], [Stack Backtrace support], [execinfo])
AST_EXT_LIB_SETUP([CAP], [POSIX 1.e capabilities], [cap])
AST_EXT_LIB_SETUP([CURL], [cURL], [curl])
@@ -626,6 +629,8 @@ AST_EXT_LIB_CHECK([OGG], [ogg], [ogg_sync_init], [])
AST_EXT_LIB_CHECK([OSPTK], [osptk], [OSPPCryptoDecrypt], [osp/osp.h], [-lcrypto -lssl])
+AST_EXT_LIB_CHECK([BKTR], [execinfo], [backtrace], [execinfo.h], [-lexecinfo])
+
# possible places for oss definitions
AST_EXT_LIB_CHECK([OSS], [ossaudio], [], [linux/soundcard.h])
AST_EXT_LIB_CHECK([OSS], [ossaudio], [], [sys/soundcard.h])