aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-02 15:57:43 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-02 15:57:43 +0000
commitd6f4c64765e7cf6040d8f32aeefa19fb5f5dbea2 (patch)
tree51fb8b111a8ecb0ffe6e0dc5ab10d55f06f3ea4b /configure.ac
parent28987321f8bb385bde1958993769bf4b7fb9e2a4 (diff)
After determining that the version of spandsp installed is an acceptable version,
do a build and link test to ensure that the library is usable, and that libtiff is also available git-svn-id: http://svn.digium.com/svn/asterisk/trunk@119799 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33ec19514..f73dd5501 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1297,6 +1297,13 @@ AST_C_COMPILE_CHECK([SPANDSP], [
#endif
], [spandsp/version.h])
+if test "x${PBX_SPANDSP}" = "x1" ; then
+ # We found the correct version in the header, now let's make sure it links
+ # properly, and that libtiff is available
+ PBX_SPANDSP=0
+ AST_EXT_LIB_CHECK([SPANDSP], [spandsp], [span_set_message_handler], [spandsp.h], [-ltiff])
+fi
+
AST_EXT_LIB_CHECK([SS7], [ss7], [ss7_pollflags], [libss7.h])
if test "${USE_PWLIB}" != "no"; then