aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-01 23:54:44 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-01 23:54:44 +0000
commitd27b1568999a55a32a0a931ae20322e3e7a000e9 (patch)
treecb3e020128c8addb56186a887d8d016b29b67515 /configure.ac
parentbae4af0cd7b45ca26c263de927e961a950b472ad (diff)
Merged revisions 145692 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r145692 | seanbright | 2008-10-01 19:48:16 -0400 (Wed, 01 Oct 2008) | 7 lines Try a test compile using the GMime library. Some distros install gmime-config in the base package instead of the -devel package. Now we print a notice and disable GMime support instead of bombing during the main compilation. (closes issue #13583) Reported by: arkadia ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.1@145694 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0dee0f35..337f6aa81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1437,6 +1437,34 @@ fi
AST_EXT_TOOL_CHECK([GMIME], [gmime])
+if test "$PBX_GMIME" = "1";
+then
+ saved_libs="${LIBS}"
+ saved_cflags="${CFLAGS}"
+ LIBS="${LIBS} ${GMIME_LIB}"
+ CFLAGS="${CFLAGS} ${GMIME_INCLUDE}"
+ AC_MSG_CHECKING(for g_mime_check_version)
+ AC_LINK_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <gmime/gmime.h>],
+ [gboolean q = g_mime_check_version(0,0,0);])
+ ],
+ [ AC_MSG_RESULT(yes)
+ PBX_GMIME=1
+ ],
+ [ AC_MSG_RESULT(no)
+ AC_MSG_NOTICE([***])
+ AC_MSG_NOTICE([*** It appears that you do not have the gmime development package installed.])
+ AC_MSG_NOTICE([*** Please install it to include ${GMIME_DESCRIP} support.])
+ AC_MSG_NOTICE([***])
+ PBX_GMIME=0
+ ]
+ )
+ LIBS="${saved_libs}"
+ CFLAGS="${saved_cflags}"
+fi
+
AST_EXT_LIB_CHECK([HOARD], [hoard], [malloc], [])
AST_EXT_LIB_CHECK([FREETDS], [sybdb], [dbinit], [sybdb.h])