aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-16 21:24:47 +0000
committermmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-16 21:24:47 +0000
commitc17227553064a37808ef76b011be0ed69c9fe5b2 (patch)
tree9d45f5888c43ce3575361f271ea38baf3829c9db /configure.ac
parentc3dc265b337814280db7a436a680fee0c2fc7cb0 (diff)
Merged revisions 150210 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r150210 | mmichelson | 2008-10-16 16:23:38 -0500 (Thu, 16 Oct 2008) | 12 lines Change configure script to search for openais in both /usr/lib and /usr/lib64 since some distros place 64-bit libraries only in the /usr/lib64 directory. (closes issue #13721) Reported by: jcollie Patches: 0007-Look-in-64bit-dirs-for-openais.patch uploaded by jcollie (license 412) ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.1@150211 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 41f4e385a..9a44725f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1387,7 +1387,7 @@ PBX_AIS=0
# OpenAIS installs its libraries into /usr/lib/openais by default, so check there
-AST_EXT_LIB_CHECK([OPENAIS], [SaClm], [saClmInitialize], [openais/saClm.h], [-L/usr/lib/openais])
+AST_EXT_LIB_CHECK([OPENAIS], [SaClm], [saClmInitialize], [openais/saClm.h], [-L/usr/lib/openais -L/usr/lib64/openais])
if test "${PBX_OPENAIS}" = 1; then
PBX_AIS=1
@@ -1396,7 +1396,7 @@ if test "${PBX_OPENAIS}" = 1; then
AIS_LIB="-lSaEvt ${OPENAIS_LIB}"
else
AIS_INCLUDE="-I/usr/include/openais"
- AIS_LIB="-lSaClm -lSaEvt -L/usr/lib/openais"
+ AIS_LIB="-lSaClm -lSaEvt -L/usr/lib/openais -L/usr/lib64/openais"
fi
fi