aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-02-18 20:16:31 +0000
committerjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-02-18 20:16:31 +0000
commit9d7a3e8f3e77c20ff9112dedba6b5c481957e1e7 (patch)
tree7498170296ac867e222a7c86f3480bcd809b4e6b /configure.ac
parent67cf0ded6dba8e0f9b37e735d3b50405a0205b10 (diff)
Merged revisions 177162 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r177162 | jpeeler | 2009-02-18 14:11:57 -0600 (Wed, 18 Feb 2009) | 14 lines Modify h323 to build against PTLib as well as the older PWLib Several changes in PTLib have occurred requiring build time detection. Changes accounted for include the library name change, config option change, install location change, and a boolean type change which is handled by ast_ptlib.h. Also, the sed check has been modified to properly work with autoconf >= 2.62. (closes issue #14224) Reported by: bergolth Patches: asterisk-autoconf-sed.patch uploaded by bergolth (license 661) asterisk-pwlib-v3.patch uploaded by bergolth (license 661) Tested by: jpeeler ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.1@177164 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e0d046675..44ecaf0f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1371,7 +1371,7 @@ if test "${USE_PWLIB}" != "no"; then
PWLIBDIR="${PWLIB_DIR}"
fi
AST_CHECK_PWLIB()
- AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2])
+ AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2], [P[[WT]]LIB_VERSION])
if test "${HAS_PWLIB:-unset}" != "unset"; then
AST_CHECK_PWLIB_PLATFORM()
@@ -1381,7 +1381,7 @@ if test "${USE_PWLIB}" != "no"; then
AST_CHECK_PWLIB_BUILD([PWLib], [PWLIB],
[Define if your system has the PWLib libraries.],
[#include "ptlib.h"],
- [BOOL q = PTime::IsDaylightSavings();])
+ [int q = (int) PTime::IsDaylightSavings();])
fi
fi