aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortzafrir <tzafrir@f38db490-d61c-443f-a65b-d21fe96a405b>2009-10-27 00:16:39 +0000
committertzafrir <tzafrir@f38db490-d61c-443f-a65b-d21fe96a405b>2009-10-27 00:16:39 +0000
commit6adce6a9bfc2286980eb5efcce11ee488fa2224c (patch)
treeb99c0d9e19b1f2ffabdb1a6dd3b57562d3be91a6 /configure.ac
parent6521c79096307f5a43f0030c53245a2e419e6bb9 (diff)
detect ARM Linux EABI OSARCH as linux-gnu instead of linux-gnueabi
* Set OSARCH to linux-gnu even if host_os is linux-gnueabi * When checking if we are Linux, check OSARCH rather than host_os The newer ARM ABI ("EABI") shows the OS name 'linux-gnueabi' rather than 'linux-gnu' . This patch sets OSARCH to be 'linux-gnu' even in such a case. OSARCH is tested for the value of 'linux-gnu' in one or two places in the tree. This patch also fixes the check libcap to check for $OSARCH rather than $host_os . See also: http://wiki.debian.org/ArmEabiPort Merged revisions 225957 via svnmerge from http://svn.digium.com/svn/asterisk/branches/1.4 Merged revisions 226018 via svnmerge from http://svn.digium.com/svn/asterisk/trunk git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.2@226055 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 38f4c6c2c..49ec5c433 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,9 @@ case "${host_os}" in
OSARCH=cygwin
PBX_WINARCH=1
;;
+ linux-gnueabi)
+ OSARCH=linux-gnu
+ ;;
*)
OSARCH=${host_os}
;;
@@ -656,7 +659,7 @@ AST_EXT_LIB_CHECK([ALSA], [asound], [snd_spcm_init], [alsa/asoundlib.h], [-lm -l
AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
-if test "x${host_os}" = "xlinux-gnu" ; then
+if test "x${OSARCH}" = "xlinux-gnu" ; then
AST_EXT_LIB_CHECK([CAP], [cap], [cap_from_text], [sys/capability.h])
fi