aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-08-08 18:19:33 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-08-08 18:19:33 +0000
commit3944364da619c7f961e1a1dee02b53f31212d70f (patch)
treef7c4ca48d6c382b1232d3ed559ccda5ad8397578 /configure.ac
parent385b99a0ae1cbadd866c74e94b07e537c8161676 (diff)
Bring in the configure and makeopts jazz for -Wshadow, but don't add it to the
Makefile yet. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@136819 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 118861969..b0dee0f35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -491,14 +491,24 @@ AC_SUBST(AST_DECLARATION_AFTER_STATEMENT)
AC_MSG_CHECKING(for -fno-strict-overflow)
if $(${CC} -O2 -fno-strict-overflow -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
- AC_MSG_RESULT(yes)
- AST_NO_STRICT_OVERFLOW=-fno-strict-overflow
+ AC_MSG_RESULT(yes)
+ AST_NO_STRICT_OVERFLOW=-fno-strict-overflow
else
AC_MSG_RESULT(no)
AST_NO_STRICT_OVERFLOW=
fi
AC_SUBST(AST_NO_STRICT_OVERFLOW)
+AC_MSG_CHECKING(for -Wshadow)
+if $(${CC} -Wshadow -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
+ AC_MSG_RESULT(yes)
+ AST_SHADOW_WARNINGS=-Wshadow
+else
+ AC_MSG_RESULT(no)
+ AST_SHADOW_WARNINGS=
+fi
+AC_SUBST(AST_SHADOW_WARNINGS)
+
AC_MSG_CHECKING(for sysinfo)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <sys/sysinfo.h>],