aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-05-08 02:41:48 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-05-08 02:41:48 +0000
commit274fd2b1f0f9b26c714ce1183fd6012702b93f82 (patch)
treeabd74546f8ff1e485ff13af792f1972f0b8d8b73 /configure.ac
parentedf0a80ec16429fc8c68fb809644733634698901 (diff)
Merged revisions 262048 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r262048 | tilghman | 2010-05-07 21:40:01 -0500 (Fri, 07 May 2010) | 2 lines Use CPPFLAGS to pass PTHREAD_CFLAGS for vpb only ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.2@262051 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 583b255bb..4b8051acb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1655,7 +1655,6 @@ AC_LANG_PUSH(C++)
if test "${USE_VPB}" != "no"; then
AC_MSG_CHECKING(for vpb_open in -lvpb)
saved_libs="${LIBS}"
- saved_cflags="${CFLAGS}"
saved_cppflags="${CPPFLAGS}"
if test "x${VPB_DIR}" != "x"; then
if test -d ${VPB_DIR}/lib; then
@@ -1667,7 +1666,7 @@ if test "${USE_VPB}" != "no"; then
CPPFLAGS="${CPPFLAGS} -I${VPB_DIR}/include"
fi
LIBS="${PTHREAD_LIBS} ${LIBS} -lvpb"
- CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+ CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}"
AC_LINK_IFELSE(
[
AC_LANG_PROGRAM(
@@ -1681,7 +1680,6 @@ if test "${USE_VPB}" != "no"; then
ac_cv_lib_vpb_vpb_open="no"
]
)
- CFLAGS="${saved_cflags}"
LIBS="${saved_libs}"
CPPFLAGS="${saved_cppflags}"
if test "${ac_cv_lib_vpb_vpb_open}" = "yes"; then