aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-18 23:58:51 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-18 23:58:51 +0000
commite2cff3939787eafa213a2db6bd7d056cbabc63f8 (patch)
treee37319e4bc3621bd1b9a9aa1388ba828077e17e4 /configure.ac
parent6a59a8232e102845b43547608ed3b0672b806093 (diff)
Actually check the return value of epoll_create to make sure it works.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@79972 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40ee8c11f..a1862937b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -334,7 +334,11 @@ AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_PREFER_WRITER_NP], [PTHREAD_RWLOCK_PREFER_WRI
AC_MSG_CHECKING(for working epoll support)
AC_LINK_IFELSE(
-AC_LANG_PROGRAM([#include <sys/epoll.h>], [epoll_create(10);]),
+AC_LANG_PROGRAM([#include <sys/epoll.h>], [int res = epoll_create(10);
+ if (res < 0)
+ return 1;
+ close (res);
+ return 0;]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_EPOLL], 1, [Define to 1 if your system has working epoll support.]),
AC_MSG_RESULT(no)