aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortzafrir <tzafrir@f38db490-d61c-443f-a65b-d21fe96a405b>2009-10-26 23:13:28 +0000
committertzafrir <tzafrir@f38db490-d61c-443f-a65b-d21fe96a405b>2009-10-26 23:13:28 +0000
commitcce295226a11230f38f7aa87323f5fc3a0afd406 (patch)
tree9db5559215dca177ae0507c67cd44f1961bf9aeb /configure.ac
parentbe9dac4422c1813990636e71bc0560b13f93f226 (diff)
detect ARM Linux EABI OSARCH as linux-gnu instead of linux-gnueabi
* Set OSARCH to linux-gnu even if host_os is linux-gnueabi * When checking if we are Linux, check OSARCH rather than host_os The newer ARM ABI ("EABI") shows the OS name 'linux-gnueabi' rather than 'linux-gnu' . This patch sets OSARCH to be 'linux-gnu' even in such a case. OSARCH is tested for the value of 'linux-gnu' in one or two places in the tree. This patch also fixes the check libcap to check for $OSARCH rather than $host_os . See also: http://wiki.debian.org/ArmEabiPort Merged revisions 225957 via svnmerge from http://svn.digium.com/svn/asterisk/branches/1.4 Merged revisions 226018 via svnmerge from http://svn.digium.com/svn/asterisk/trunk git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@226019 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c8fded08..9ee94fd6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,9 @@ case "${host_os}" in
OSARCH=cygwin
WINARCH=1
;;
+ linux-gnueabi)
+ OSARCH=linux-gnu
+ ;;
*)
OSARCH=${host_os}
;;
@@ -624,7 +627,7 @@ AST_EXT_LIB_CHECK([ALSA], [asound], [snd_spcm_init], [alsa/asoundlib.h], [-lm -l
AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
-if test "x${host_os}" = "xlinux-gnu" ; then
+if test "x${OSARCH}" = "xlinux-gnu" ; then
AST_EXT_LIB_CHECK([CAP], [cap], [cap_from_text], [sys/capability.h])
fi