aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-04-27 01:30:44 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-04-27 01:30:44 +0000
commit3b3b35f2c2469ff70987d58df1b5034ec7e269b9 (patch)
tree952d2887e59f1c9249be6c5d4e84029d2961fe4a /configure.ac
parent4c12db18d80e773b45a96c3116ed790d3025d7df (diff)
Merged revisions 114696 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ................ r114696 | seanbright | 2008-04-26 21:28:32 -0400 (Sat, 26 Apr 2008) | 13 lines Merged revisions 114695 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r114695 | seanbright | 2008-04-26 21:26:15 -0400 (Sat, 26 Apr 2008) | 5 lines When we don't explicitly pass a path to the --with-tds configure option, we may end up finding tds.h in /usr/local/include instead of /usr/include. If this happens, the grep that looks for the version (from tdsver.h) will fail and we'll have some problems during the build. ........ ................ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@114697 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 498bf6983..b225f0ab8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1336,9 +1336,19 @@ AST_EXT_TOOL_CHECK([GMIME], [gmime])
AST_EXT_LIB_CHECK([FREETDS], [tds], [tds_version], [tds.h])
if test "${PBX_FREETDS}" != "0";
then
- case `grep TDS_VERSION_NO ${FREETDS_DIR:-/usr}/include/tdsver.h` in
- *0.64*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_64"
+ if test "${FREETDS_DIR}x" = "x";
+ then
+ for tds_dir in /usr /usr/local;
+ do
+ if test -f "${tds_dir}/include/tdsver.h";
+ then
+ FREETDS_DIR="${tds_dir}"
+ fi
+ done
+ fi
+ case `${GREP} TDS_VERSION_NO ${FREETDS_DIR:-/usr}/include/tdsver.h` in
+ *0.64*)
+ FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_64"
;;
*0.63*)
FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_63"