aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-02-18 20:15:37 +0000
committerjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-02-18 20:15:37 +0000
commit27e82e2ee03e30aa120d18e457a41ebfb3398e16 (patch)
tree4fec9b1815a3d73cc8458ce4216b8b3e7938d3a7 /configure.ac
parent93675cf7dfcd7c9e1f0305ca4c1453855c7984ea (diff)
Merged revisions 177162 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r177162 | jpeeler | 2009-02-18 14:11:57 -0600 (Wed, 18 Feb 2009) | 14 lines Modify h323 to build against PTLib as well as the older PWLib Several changes in PTLib have occurred requiring build time detection. Changes accounted for include the library name change, config option change, install location change, and a boolean type change which is handled by ast_ptlib.h. Also, the sed check has been modified to properly work with autoconf >= 2.62. (closes issue #14224) Reported by: bergolth Patches: asterisk-autoconf-sed.patch uploaded by bergolth (license 661) asterisk-pwlib-v3.patch uploaded by bergolth (license 661) Tested by: jpeeler ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@177163 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 09f4de278..92ab6c692 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1351,7 +1351,7 @@ if test "${USE_PWLIB}" != "no"; then
PWLIBDIR="${PWLIB_DIR}"
fi
AST_CHECK_PWLIB()
- AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2])
+ AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2], [P[[WT]]LIB_VERSION])
if test "${HAS_PWLIB:-unset}" != "unset"; then
AST_CHECK_PWLIB_PLATFORM()
@@ -1361,7 +1361,7 @@ if test "${USE_PWLIB}" != "no"; then
AST_CHECK_PWLIB_BUILD([PWLib], [PWLIB],
[Define if your system has the PWLib libraries.],
[#include "ptlib.h"],
- [BOOL q = PTime::IsDaylightSavings();])
+ [int q = (int) PTime::IsDaylightSavings();])
fi
fi