aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-10 16:27:03 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-10 16:27:03 +0000
commit1d0d1a7f8fe3c7e64eb933ec7243f30ce17c2028 (patch)
treef9772dd18085753779bd775cba67eae2fdf7cdc4 /configure.ac
parenta8236f3bdba9ae7d19dc3484597796b57819e505 (diff)
Use AST_EXT_TOOL_CHECK() for the GTK check again. I changed this to an inline
implementation to fix a small bug, but after a discussion with rizzo, I went to change it back. Also, it turns out that the implementation of the macro already supported what was needed to fix the problem. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@97767 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index d3d14259f..5e2a56a25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1161,16 +1161,7 @@ AST_EXT_LIB_CHECK([X11], [X11], [XOpenDisplay], [X11/Xlib.h],,, [standard_path])
AST_EXT_LIB_CHECK([X11], [X11], [XOpenDisplay], [X11/Xlib.h],, [-I/usr/X11R6/include], [X11R6])
PBX_GTK=0
-AC_CHECK_TOOL(GTKCONFIG, gtk-config, No)
-if test ! "x${GTKCONFIG}" = xNo; then
- GTK_INCLUDE=$(${GTKCONFIG} --cflags gthread)
- GTK_LIB=$(${GTKCONFIG} --libs gthread)
- PBX_GTK=1
- AC_DEFINE([HAVE_GTK], 1, [Define if your system has the GTK libraries.])
-fi
-AC_SUBST(PBX_GTK)
-AC_SUBST(GTK_INCLUDE)
-AC_SUBST(GTK_LIB)
+AST_EXT_TOOL_CHECK([GTK], [gtk], [--cflags gthread], [--libs gthread])
PBX_GTK2=0
AC_CHECK_TOOL(PKGCONFIG, pkg-config, No)