aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-10 16:15:43 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-10 16:15:43 +0000
commitcfcf4c9f8cdfa495859d18d9026c5e29b04ddb8d (patch)
treebc9adc5283e515d21adf7bc408fe60a2032633a1 /configure.ac
parentd3421c995aaae1961dcd2f053a235afe374b36e1 (diff)
Merged revisions 97734 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r97734 | russell | 2008-01-10 10:10:09 -0600 (Thu, 10 Jan 2008) | 4 lines Remove pbx_kdeconsole from the tree. It hasn't worked in ages, and nobody has complained. (closes issue #11706, reported by caio1982) ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@97745 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac65
1 files changed, 0 insertions, 65 deletions
diff --git a/configure.ac b/configure.ac
index 286f19d70..d3d14259f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,7 +233,6 @@ AST_EXT_LIB_SETUP([PRI], [ISDN PRI], [pri])
AST_EXT_LIB_SETUP([SS7], [ISDN SS7], [ss7])
AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
-AST_EXT_LIB_SETUP([QT], [Qt], [qt])
AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
AST_EXT_LIB_SETUP([SPEEX], [Speex], [speex])
AST_EXT_LIB_SETUP([SQLITE], [SQLite], [sqlite])
@@ -980,70 +979,6 @@ if test "${PBX_PWLIB}" = "1" -a "${USE_OPENH323}" != "no" ; then
[${PWLIB_INCLUDE}], [${PWLIB_LIB}])
fi
-AC_LANG_PUSH(C++)
-
-if test "${USE_QT}" != "no"; then
- AC_MSG_CHECKING(for QDate in -lqt)
- saved_libs="${LIBS}"
- saved_cppflags="${CPPFLAGS}"
- if test "x${QT_DIR}" != "x"; then
- LIBS="${LIBS} -L${QT_DIR}/lib"
- CPPFLAGS="${CPPFLAGS} -I${QT_DIR}/include"
- fi
- LIBS="${LIBS} -lqt"
- qtlib="qt"
- AC_LINK_IFELSE(
- [
- AC_LANG_PROGRAM(
- [#include <qt3/qdatetime.h>],
- [QDate date();])
- ],
- [ac_cv_lib_qt_qt_date="yes"],
- [ac_cv_lib_qt_qt_date="no"])
- LIBS="${saved_libs}"
- CPPFLAGS="${saved_cppflags}"
-
- if test "${ac_cv_lib_qt_qt_date}" = "no"; then
- saved_libs="${LIBS}"
- saved_cppflags="${CPPFLAGS}"
- if test "x${QT_DIR}" != "x"; then
- LIBS="${LIBS} -L${QT_DIR}/lib"
- CPPFLAGS="${CPPFLAGS} -I${QT_DIR}/include"
- fi
- LIBS="${LIBS} -lqt-mt"
- qtlib="qt-mt"
- AC_LINK_IFELSE(
- [
- AC_LANG_PROGRAM(
- [#include <qt3/qdatetime.h>],
- [QDate date();])
- ],
- [ac_cv_lib_qt_qt_date="yes"],
- [ac_cv_lib_qt_qt_date="no"])
- LIBS="${saved_libs}"
- CPPFLAGS="${saved_cppflags}"
- fi
-
- if test "${ac_cv_lib_qt_qt_date}" = "yes"; then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- fi
-
- if test "${ac_cv_lib_qt_qt_date}" = "yes"; then
- QT_LIB="-l${qtlib}"
- if test "${QT_DIR}" != ""; then
- QT_LIB="-L${QT_DIR}/lib ${QT_LIB}"
- QT_INCLUDE="-I${QT_DIR}/include"
- fi
- PBX_QT=1
- AC_DEFINE([HAVE_QT], 1, [Define if your system has the Qt library])
- AC_PATH_TOOL(QTMOC, moc, No)
- fi
-fi
-
-AC_LANG_POP
-
LUA_INCLUDE="-I/usr/include/lua5.1"
LUA_LIB="-llua5.1"
AST_EXT_LIB_CHECK([LUA], [lua5.1], [luaL_newstate], [lua5.1/lua.h])