aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-02-15 15:11:23 +0000
committermmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-02-15 15:11:23 +0000
commitcc05387ba319a0653827a3344777a7aa60d783c7 (patch)
treef58919b71477059067309a1a430060d4336ddb62 /configure.ac
parent950c086a0d29ed37ebf1b01e1ee65a42d9de7157 (diff)
Merging of changes from 1.4 revision 103713.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@103715 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4838de4d8..073ec0fa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -648,13 +648,13 @@ fi
AST_EXT_LIB_CHECK([IKSEMEL], [iksemel], [iks_start_sasl], [iksemel.h])
if test "${USE_IMAP_TK}" != "no"; then
+ saved_cppflags="${CPPFLAGS}"
+ saved_libs="${LIBS}"
switch_to_system_on_failure="no"
if test "${IMAP_TK_DIR}" = ""; then
IMAP_TK_DIR=`pwd`"/../imap-2004g"
switch_to_system_on_failure="yes"
fi
- saved_cppflags="${CPPFLAGS}"
- saved_libs="${LIBS}"
if test "${IMAP_TK_DIR}" != "system"; then
AC_MSG_CHECKING(for UW IMAP Toolkit c-client library)
if test -f "${IMAP_TK_DIR}/c-client/LDFLAGS"; then
@@ -1032,8 +1032,6 @@ if test "${USE_IMAP_TK}" != "no"; then
fi
if test "${ac_cv_imap_tk}" = "yes"; then
AC_MSG_RESULT(yes)
- CPPFLAGS="${saved_cppflags}"
- LIBS="${saved_libs}"
IMAP_TK_LIB="${imap_libs} "`echo ${imap_ldflags}`
IMAP_TK_INCLUDE="${imap_include}"
PBX_IMAP_TK=1
@@ -1044,6 +1042,8 @@ if test "${USE_IMAP_TK}" != "no"; then
else
AC_MSG_RESULT(no)
fi
+ CPPFLAGS="${saved_cppflags}"
+ LIBS="${saved_libs}"
fi
AST_EXT_LIB_CHECK([JACK], [jack], [jack_activate], [jack/jack.h])