aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-09-07 12:32:04 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-09-07 12:32:04 +0000
commit3b753ec1757735799e81818c07c04bb442a6efcb (patch)
tree51ffe21be6d1be69a96cb1f787ee3f629e15fbc3 /configure.ac
parent6a6c524ff80cbeb2c99c558e1cbe3eef131aba3c (diff)
Don't check for epoll support when cross compiling.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@81873 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a1862937b..cdfe2021b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,6 +332,8 @@ fi
AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_INITIALIZER], [PTHREAD_RWLOCK_INITIALIZER], [pthread.h])
AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_PREFER_WRITER_NP], [PTHREAD_RWLOCK_PREFER_WRITER_NP], [pthread.h])
+if test "${cross_compiling}" = "no";
+then
AC_MSG_CHECKING(for working epoll support)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <sys/epoll.h>], [int res = epoll_create(10);
@@ -343,6 +345,7 @@ AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_EPOLL], 1, [Define to 1 if your system has working epoll support.]),
AC_MSG_RESULT(no)
)
+fi
AC_MSG_CHECKING(for compiler atomic operations)
AC_LINK_IFELSE(