aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2006-06-14 02:23:29 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2006-06-14 02:23:29 +0000
commit2ce6a2d8468fea20230f8694fc77ff16b2ca321b (patch)
treed707cd055b6330f4dde16f4352e6f70db1a48d74 /configure.ac
parentd433b2eaba39b9545398648e02f5aae193ab5fe2 (diff)
use the proper test for compiler atomics
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@33995 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 34ea602cb..23813573d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -724,7 +724,7 @@ AC_FUNC_VPRINTF
AC_CHECK_FUNCS([atexit bzero dup2 endpwent floor ftruncate getcwd gethostbyname gethostname gettimeofday inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap pow putenv re_comp regcomp rint select setenv socket sqrt strcasecmp strchr strcspn strdup strerror strncasecmp strndup strnlen strrchr strsep strspn strstr strtol unsetenv utime strtoq strcasestr asprintf vasprintf])
echo -n "checking for compiler atomic operations... "
-AC_COMPILE_IFELSE(
+AC_LINK_IFELSE(
AC_LANG_PROGRAM([], [int foo1; int foo2 = __sync_fetch_and_add(&foo1, 1);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_GCC_ATOMICS], 1, [Define to 1 if your GCC C compiler provides atomic operations.]),