aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-11-17 06:33:07 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-11-17 06:33:07 +0000
commit1ccd0d8633d2f4d7f8c69838676bbbcfee001a50 (patch)
treed386269f08375e9b9476aff1b8a87ad8e8abd780 /configure.ac
parent85a28052d3c1b1d8b1f923f99b0ad4405aacd875 (diff)
Update the configure script check for sys/poll.h to also provide the result in
include/asterisk/autoconfig.h. Also, move the conditional include of sys/poll.h or asterisk/poll-compat.h into asterisk/config.h instead of the two headers it existed in before. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@89361 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a56fbecc..aa8966802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,10 @@ AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent ftruncate getcwd gethostbyna
AC_CHECK_FUNCS([glob])
AC_CHECK_FUNCS([timersub])
-AC_CHECK_HEADER([sys/poll.h], [HAS_POLL=1],)
+AC_CHECK_HEADER([sys/poll.h],
+ [HAS_POLL=1]
+ AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),
+ )
AC_SUBST(HAS_POLL)
# https support (in main/http.c) uses funopen on BSD systems,