aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-11-03 00:52:05 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-11-03 00:52:05 +0000
commitdd99ea8e6203f1af361ed20e10680ccdc87d1920 (patch)
tree6f934a51635fc46632de5c4240863b7aac364cfa /configure.ac
parentd3d057390c26ce35b54750705377c4d3ff4e42bd (diff)
Merge revision 153709 from trunk
------------------------------------------------------------------------ r153709 | kpfleming | 2008-11-02 17:34:39 -0600 (Sun, 02 Nov 2008) | 3 lines instead of trying to forcibly load res_agi when app_stack is loaded (even if the administrator didn't want it loaded), use GCC weak symbols to determine whether it was loaded already or not; if it was loaded, then use it. ------------------------------------------------------------------------ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@153745 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1a269738..9d6b4416e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -451,6 +451,7 @@ AST_GCC_ATTRIBUTE(const)
AST_GCC_ATTRIBUTE(unused)
AST_GCC_ATTRIBUTE(always_inline)
AST_GCC_ATTRIBUTE(deprecated)
+AST_GCC_ATTRIBUTE(weak)
AC_MSG_CHECKING(for -ffunction-sections support)
saved_CFLAGS="${CFLAGS}"