aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-10 16:10:09 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-10 16:10:09 +0000
commitbc283498259421c2ba995ab45c4207f35ef95d9c (patch)
tree6d806b31db2a18cea2e9c771aae331c0c1e52af9 /configure.ac
parent56b4420d6402fad8c65e3531f4bc255a1adcd33f (diff)
Remove pbx_kdeconsole from the tree. It hasn't worked in ages, and nobody has
complained. (closes issue #11706, reported by caio1982) git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@97734 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac73
1 files changed, 0 insertions, 73 deletions
diff --git a/configure.ac b/configure.ac
index cc065c605..34ceebaaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,7 +196,6 @@ AST_EXT_LIB_SETUP([PGSQL], [PostgreSQL], [postgres])
AST_EXT_LIB_SETUP([PRI], [ISDN PRI], [pri])
AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
-AST_EXT_LIB_SETUP([QT], [Qt], [qt])
AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
AST_EXT_LIB_SETUP([SPEEX], [Speex], [speex])
AST_EXT_LIB_SETUP([SQLITE], [SQLite], [sqlite])
@@ -871,78 +870,6 @@ if test "${USE_OPENH323}" != "no" -a "x${ac_cv_lib_OPENH323}" != "xyes" -a -n "$
exit 1
fi
-
-AC_LANG_PUSH(C++)
-
-if test "${USE_QT}" != "no"; then
- AC_MSG_CHECKING(for QDate in -lqt)
- saved_libs="${LIBS}"
- saved_cppflags="${CPPFLAGS}"
- if test "x${QT_DIR}" != "x"; then
- LIBS="${LIBS} -L${QT_DIR}/lib"
- CPPFLAGS="${CPPFLAGS} -I${QT_DIR}/include"
- fi
- LIBS="${LIBS} -lqt"
- qtlib="qt"
- AC_LINK_IFELSE(
- [
- AC_LANG_PROGRAM(
- [#include <qt3/qdatetime.h>],
- [QDate date();])
- ],
- [ac_cv_lib_qt_qt_date="yes"],
- [ac_cv_lib_qt_qt_date="no"])
- LIBS="${saved_libs}"
- CPPFLAGS="${saved_cppflags}"
-
- if test "${ac_cv_lib_qt_qt_date}" = "no"; then
- saved_libs="${LIBS}"
- saved_cppflags="${CPPFLAGS}"
- if test "x${QT_DIR}" != "x"; then
- LIBS="${LIBS} -L${QT_DIR}/lib"
- CPPFLAGS="${CPPFLAGS} -I${QT_DIR}/include"
- fi
- LIBS="${LIBS} -lqt-mt"
- qtlib="qt-mt"
- AC_LINK_IFELSE(
- [
- AC_LANG_PROGRAM(
- [#include <qt3/qdatetime.h>],
- [QDate date();])
- ],
- [ac_cv_lib_qt_qt_date="yes"],
- [ac_cv_lib_qt_qt_date="no"])
- LIBS="${saved_libs}"
- CPPFLAGS="${saved_cppflags}"
- fi
-
- if test "${ac_cv_lib_qt_qt_date}" = "yes"; then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- fi
-
- if test "${ac_cv_lib_qt_qt_date}" = "yes"; then
- QT_LIB="-l${qtlib}"
- if test "${QT_DIR}" != ""; then
- QT_LIB="-L${QT_DIR}/lib ${QT_LIB}"
- QT_INCLUDE="-I${QT_DIR}/include"
- fi
- PBX_QT=1
- AC_DEFINE([HAVE_QT], 1, [Define if your system has the Qt library])
- AC_PATH_TOOL(QTMOC, moc, No)
- elif test -n "${QT_MANDATORY}";
- then
- AC_MSG_NOTICE([***])
- AC_MSG_NOTICE([*** The Qt installation on this system appears to be broken.])
- AC_MSG_NOTICE([*** Either correct the installation, or run configure])
- AC_MSG_NOTICE([*** including --without-qt.])
- exit 1
- fi
-fi
-
-AC_LANG_POP
-
AST_EXT_LIB_CHECK([RADIUS], [radiusclient-ng], [rc_read_config], [radiusclient-ng.h])
AST_EXT_LIB_CHECK([SPEEX], [speex], [speex_encode], [speex/speex.h], [-lm])