aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-15 23:53:26 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-15 23:53:26 +0000
commit20ab623907fa09cdb7abd31435950d6402b3a00a (patch)
tree21477ad858bc63ce66f1f8d38f50d24b9286bc7d /configure.ac
parent57f6f3558017c7d769d8b7df64e1737ffff25734 (diff)
Add configure script checking for GTK2 and some additional Makefile targets
to support gmenuselect git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@58947 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0a0cb3e34..dd7d8a920 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1112,6 +1112,18 @@ AC_SUBST(PBX_GTK)
AC_SUBST(GTK_INCLUDE)
AC_SUBST(GTK_LIB)
+PBX_GTK2=0
+AC_CHECK_TOOL(PKGCONFIG, pkg-config, No)
+if test ! "x${PKGCONFIG}" = xNo; then
+ GTK2_INCLUDE=$(${PKGCONFIG} gtk+-2.0 --cflags)
+ GTK2_LIB=$(${PKGCONFIG} gtk+-2.0 --libs)
+ PBX_GTK2=1
+ AC_DEFINE([HAVE_GTK2], 1, [Define if your system has the GTK2 libraries.])
+fi
+AC_SUBST(PBX_GTK2)
+AC_SUBST(GTK2_INCLUDE)
+AC_SUBST(GTK2_LIB)
+
if test "${USE_CURL}" != "no"; then
AC_PATH_TOOL([CURL_CONFIG], [curl-config], No)
if test ! x"${CURL_CONFIG}" = xNo; then