aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2009-09-10 18:19:58 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2009-09-10 18:19:58 +0000
commitd4a2be41f5adda2f9588915c4487d544e81b5b39 (patch)
treeaf528652573a8fe356363ac24f2152a1e8289060 /configure.ac
parent485b22713e3523aff57475cf656792fa41b24f65 (diff)
Merged revisions 217638 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r217638 | tilghman | 2009-09-10 13:17:14 -0500 (Thu, 10 Sep 2009) | 4 lines Verify support for wide ODBC character types before using them. (closes issue #15870) Reported by: nic_bellamy ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.2@217647 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62597f984..38f4c6c2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1607,6 +1607,20 @@ else
fi
AC_SUBST(EDITLINE_LIB)
+if test "x${PBX_UNIXODBC}" = "x1" -o "x${PBX_IODBC}" = "x1"; then
+ # Does ODBC support wide characters?
+ AC_MSG_CHECKING(whether ODBC has support for Unicode types)
+ AC_LINK_IFELSE(
+ AC_LANG_PROGRAM(
+ [#include <sql.h>
+#include <sqlext.h>],
+ [int foo = SQL_WCHAR]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_ODBC_WCHAR], [1], [Define to 1 if your ODBC library has wide (Unicode) types.]),
+ AC_MSG_RESULT(no)
+ )
+fi
+
AC_CHECK_HEADER([h323.h], [PBX_H323=1], [PBX_H323=0])
AC_SUBST(PBX_H323)