aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2009-08-28 20:05:56 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2009-08-28 20:05:56 +0000
commit3282814d00360edb2aa3cd614776f9fa03f45d05 (patch)
treea5229bf5f9f2d67adbdff7287fe57a64ebae5720 /configure.ac
parent5ed7fdc6f63281c068e0f8dc3c882785485fbb6b (diff)
Merged revisions 214696 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r214696 | kpfleming | 2009-08-28 15:01:21 -0500 (Fri, 28 Aug 2009) | 9 lines Ensure that CFLAGS and/or LDFLAGS provided to configure script are preserved. Cross-compilation environments want to provide 'defaults' for compiler and linker options, and frequently do this by specifying CFLAGS and LDFLAGS in the environment or as command-line arguments to the configure script. This patch modifies the configure script and Makefile to preserve these settings and ensure they are used in the build process. ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.2@214700 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 558ecb795..ec76807f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,12 @@ AC_REVISION($Revision$)
AC_USE_SYSTEM_EXTENSIONS # note- does not work on FreeBSD
+# preserve any CFLAGS or LDFLAGS that may be set
+CONFIG_CFLAGS="${CFLAGS}"
+CONFIG_LDFLAGS="${LDFLAGS}"
+AC_SUBST(CONFIG_CFLAGS)
+AC_SUBST(CONFIG_LDFLAGS)
+
case "${host_os}" in
freebsd*)
ac_default_prefix=/usr/local