aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-06-08 22:45:16 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-06-08 22:45:16 +0000
commit6db8e08fa31bc24296db13621a207e435834fdcd (patch)
tree22560e41c6bd633476d35dbd1a35e10e4f808891 /configure.ac
parent37bc8c80dbeba08edc962eccaaaad2f482f1cfb3 (diff)
Fix build on Mac OS X (and maybe FreeBSD, too)
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@269119 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e09aa3f1..c588301de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,6 +550,21 @@ then
AC_CHECK_FILE(/dev/urandom, AC_DEFINE([HAVE_DEV_URANDOM], 1, [Define to 1 if your system has /dev/urandom.]))
fi
+AC_MSG_CHECKING(for locale_t in locale.h)
+AC_LINK_IFELSE(
+AC_LANG_PROGRAM([#include <locale.h>], [locale_t lt = NULL]),
+AC_MSG_RESULT(yes)
+AC_DEFINE([HAVE_LOCALE_T_IN_LOCALE_H], 1, [Define to 1 if your system defines the locale_t type in locale.h]),
+AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for locale_t in xlocale.h)
+ AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([#include <xlocale.h>], [locale_t lt = NULL]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_LOCALE_T_IN_XLOCALE_H], 1, [Define to 1 if your system defines the locale_t type in xlocale.h]),
+ AC_MSG_RESULT(no)
+ )
+)
+
AC_MSG_CHECKING(for O_EVTONLY in fcntl.h)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <fcntl.h>], [int a = O_EVTONLY;]),