aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-25 22:21:30 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-25 22:21:30 +0000
commit0aeeffaa0956845b7dd0941df54eda3411329dea (patch)
tree7aee232cca984b03627beaca4794986dea17c387 /configure.ac
parente8c34cc34baa6113303d5ca1574c3aed5f2dbeed (diff)
allow tonezone to live in a different place than DAHDI/Zaptel, since dahdi-tools and dahdi-linux are now separate packages and can be installed in different places
don't include tonezone.h in dahdi_compat.h, because only a couple of modules need it get app_rpt building again after the DAHDI changes (closes issue #12911) Reported by: tzafrir git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@125132 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 79ebbe8ed..09368851f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1360,8 +1360,14 @@ fi
if test "${PBX_DAHDI}" = "1" || test "${USE_ZAPTEL}" = "no"; then
tonezone_dir="dahdi"
+ if test "x${DAHDI_DIR}" != "x"; then
+ tonezone_extra="${tonezone_extra} -I${DAHDI_DIR}/include"
+ fi
else
tonezone_dir="zaptel"
+ if test "x${ZAPTEL_DIR}" != "x"; then
+ tonezone_extra="${tonezone_extra} -I${ZAPTEL_DIR}/include"
+ fi
fi
AST_EXT_LIB_CHECK([TONEZONE], [tonezone], [tone_zone_find], [${tonezone_dir}/tonezone.h], [${tonezone_extra}])