aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2007-01-08 03:53:53 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2007-01-08 03:53:53 +0000
commitfeca4c49eb01acdb1648927b5b2ec65100f5c679 (patch)
tree1afd5f4f0e2925bb41affffee22ed4273f1f8a62 /configure.ac
parent2fec763382a82f8e8002199247cebf3d87fcf452 (diff)
since we use AC_PATH_TOOL to find tools, we should use the results it provides for us (reported by Brian Capouch on the asterisk-dev list)
git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@49866 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4caa617cd..b70b95e25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -629,7 +629,7 @@ if test "${USE_NETSNMP}" != "no"; then
fi
fi
if test x"${NETSNMP_CONFIG}" != xNo; then
- NETSNMP_libs=`net-snmp-config --agent-libs`
+ NETSNMP_libs=`${NETSNMP_CONFIG} --agent-libs`
AC_CHECK_LIB([netsnmp], [snmp_register_callback], AC_DEFINE_UNQUOTED([HAVE_NETSNMP], 1,
[Define to indicate the Net-SNMP library]), [], ${NETSNMP_libs})
@@ -696,8 +696,8 @@ if test "${USE_PGSQL}" != "no"; then
fi
fi
if test "${PG_CONFIG}" != No; then
- PGSQL_libdir=`pg_config --libdir`
- PGSQL_includedir=`pg_config --includedir`
+ PGSQL_libdir=`${PG_CONFIG} --libdir`
+ PGSQL_includedir=`${PG_CONFIG} --includedir`
AC_CHECK_LIB([pq], [PQexec], AC_DEFINE_UNQUOTED([HAVE_PGSQL], 1,
[Define to indicate the PostgreSQL library]), [], -L${PGSQL_libdir} -lz)
@@ -1064,12 +1064,12 @@ AC_SUBST(GTK_INCLUDE)
AC_SUBST(GTK_LIB)
if test "${USE_CURL}" != "no"; then
- AC_PATH_TOOL([CURL], [curl-config], No)
- if test ! x"${CURL}" = xNo; then
+ AC_PATH_TOOL([CURL_CONFIG], [curl-config], No)
+ if test ! x"${CURL_CONFIG}" = xNo; then
# check for version
- if test $(printf "%d" 0x$(curl-config --vernum)) -ge $(printf "%d" 0x070907); then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
+ if test $(printf "%d" 0x$(${CURL_CONFIG} --vernum)) -ge $(printf "%d" 0x070907); then
+ CURL_INCLUDE=$(${CURL_CONFIG} --cflags)
+ CURL_LIB=$(${CURL_CONFIG} --libs)
PBX_CURL=1
AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
fi