aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-19 17:55:34 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-19 17:55:34 +0000
commitab6a6c0cf07f19ca93d5ce72475990d5fff5833d (patch)
treef91de7248a352ef848d455669b556c6580848a79 /configure.ac
parenta0ace4c2a1a228175a677a44812445b18578b073 (diff)
Detect if the installed gcc version supports the warn_unused_result attribute.
Reported by mvanbaak via IRC -dev. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@123988 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c07a03d6e..c1a33783d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -441,6 +441,7 @@ AST_GCC_ATTRIBUTE(unused)
AST_GCC_ATTRIBUTE(always_inline)
AST_GCC_ATTRIBUTE(deprecated)
AST_GCC_ATTRIBUTE(sentinel)
+AST_GCC_ATTRIBUTE(warn_unused_result)
AC_MSG_CHECKING(for -ffunction-sections support)
saved_CFLAGS="${CFLAGS}"