aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2008-05-09 16:34:08 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2008-05-09 16:34:08 +0000
commitabf60597b68d3c1a1b678f9c54f31ae14c65ff05 (patch)
treed2a8b096bf5fe2c00fe8f9d334ca33b8b0b69265 /configure.ac
parent815be572df1fb1fcf08280d763999fa6d52089b5 (diff)
Improve res_ninit and res_ndestroy autoconf logic on the Darwin platform.
git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@115579 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 26 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 432dbbaf6..aeda896e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,7 +220,7 @@ AC_FUNC_ALLOCA
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h libintl.h limits.h locale.h malloc.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h strings.h sys/file.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h termios.h unistd.h utime.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h libintl.h limits.h locale.h malloc.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h strings.h sys/file.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h termios.h unistd.h utime.h arpa/nameser.h])
AC_SYS_LARGEFILE
@@ -363,16 +363,38 @@ else
fi
AC_SUBST(AST_NO_STRICT_OVERFLOW)
+AC_SEARCH_LIBS(res_9_ninit, resolv)
AC_MSG_CHECKING(for res_ninit)
AC_LINK_IFELSE(
- AC_LANG_PROGRAM([#include <resolv.h>],
+ AC_LANG_PROGRAM([
+ #ifdef HAVE_SYS_SOCKET_H
+ #include <sys/socket.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ #include <netinet/in.h>
+ #endif
+ #ifdef HAVE_ARPA_NAMESER_H
+ #include <arpa/nameser.h>
+ #endif
+ #include <resolv.h>],
[int foo = res_ninit(NULL);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_RES_NINIT], 1, [Define to 1 if your system has the re-entrant resolver functions.])
+ AC_SEARCH_LIBS(res_9_ndestroy, resolv)
AC_MSG_CHECKING(for res_ndestroy)
AC_LINK_IFELSE(
- AC_LANG_PROGRAM([#include <resolv.h>],
- [int foo = res_ndestroy(NULL);]),
+ AC_LANG_PROGRAM([
+ #ifdef HAVE_SYS_SOCKET_H
+ #include <sys/socket.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ #include <netinet/in.h>
+ #endif
+ #ifdef HAVE_ARPA_NAMESER_H
+ #include <arpa/nameser.h>
+ #endif
+ #include <resolv.h>],
+ [res_ndestroy(NULL);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_RES_NDESTROY], 1, [Define to 1 if your system has the ndestroy resolver function.]),
AC_MSG_RESULT(no)