aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-05-24 20:44:46 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-05-24 20:44:46 +0000
commitea34e0acf43c8b916a0fbfc67e8b2faf55960d4a (patch)
tree85286d0c7f29554f373b2ce97409540b3e69ce42 /configure.ac
parented238ab53240f118abeee6ade825afc5c7afb5b5 (diff)
Merged revisions 66026 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r66026 | russell | 2007-05-24 15:42:53 -0500 (Thu, 24 May 2007) | 3 lines Checking for the strip application needs to be done with AC_PATH_TOOL instead of AC_PATH_PROG to properly handle cross compilation environments. ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@66027 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fd898c11b..1600b35d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,8 @@ AC_PROG_LN_S
AC_PROG_RANLIB
AST_CHECK_GNU_MAKE
+AC_PATH_TOOL([STRIP], [strip], :)
+
GNU_LD=0
if test "x$with_gnu_ld" = "xyes" ; then
GNU_LD=1
@@ -151,7 +153,6 @@ AC_PATH_PROG([DIRNAME], [dirname], :)
AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
AC_PATH_PROG([DOT], [dot], :)
-AC_PATH_PROG([STRIP], [strip], :)
AC_PATH_PROG([WGET], [wget], :)
AC_PATH_PROG([RUBBER], [rubber], :)
if test "${WGET}" != ":" ; then