aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-01 22:32:12 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-01 22:32:12 +0000
commite9434c1061fb27e52b98736f2704808ec4ca1c5d (patch)
treed03bc89d02b9e2489d64e92a4f910f7e7bb99100 /configure.ac
parent194f40a74cf47eeaf36e36769e5c61b39a049d84 (diff)
Add a check in the configure script to determine whether ld is GNU ld or not.
This is needed because module embedding only works for gnu ld. GNU ld is now listed as a dependency for all of the module embedding options in menuselect. (issue #8143) git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@46845 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa0683233..4f77b8752 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,4 @@
+w
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.60)
@@ -120,12 +121,19 @@ AC_PROG_CC
AC_PROG_CXX
AC_PROG_CPP
AC_PROG_CXXCPP
+AC_PROG_LD
AC_PROG_AWK
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_RANLIB
AST_CHECK_GNU_MAKE
+GNU_LD=0
+if test "x$with_gnu_ld" = "xyes" ; then
+ GNU_LD=1
+fi
+AC_SUBST(GNU_LD)
+
AC_PATH_PROG([GREP], [grep], :)
AC_PATH_PROG([AR], [ar], :)
AC_PATH_PROG([FIND], [find], :)