aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-08 01:01:46 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-08 01:01:46 +0000
commita97792f32c909455ebb8b9ccbaaf529d95709b6b (patch)
tree4efc65d665f0936a9aefc85a26fafeb09e6988f0 /configure.ac
parent4a2bb0f4fb55ce6e5500b3199918cab7b0c044ff (diff)
If we receive ZT_EVENT_REMOVED, destroy the specified channel.
(issue #7256, tzafrir) Also, update the configure script to make sure that we don't try to build chan_zap if the installed version of zaptel does not include ZT_EVENT_REMOVED. git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@58320 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 03b34a803..fd166fc88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1026,7 +1026,7 @@ if test "${USE_ZAPTEL}" != "no"; then
fi
if test "${PBX_ZAPTEL}" = 1; then
- AC_MSG_CHECKING(for ZT_TONE_DTMF_BASE in zaptel/zaptel.h)
+ AC_MSG_CHECKING(for ZT_EVENT_REMOVED in zaptel/zaptel.h)
saved_cppflags="${CPPFLAGS}"
if test "x${ZAPTEL_DIR}" != "x"; then
CPPFLAGS="${CPPFLAGS} -I${ZAPTEL_DIR}/include"
@@ -1035,7 +1035,7 @@ if test "${PBX_ZAPTEL}" = 1; then
[
AC_LANG_PROGRAM(
[#include <zaptel/zaptel.h>],
- [int foo = ZT_TONE_DTMF_BASE;])
+ [int foo = ZT_EVENT_REMOVED;])
],
[ AC_MSG_RESULT(yes)
ac_cv_zaptel_vldtmf="yes"