aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-12-01 23:16:28 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-12-01 23:16:28 +0000
commit88d37514dada9e00c0aa0604cd962f6e8c865d6c (patch)
tree7ac1f3a16b91b26b4947cf14f2499989fa424c47 /configure.ac
parent1a21925e9bf26521a510b27548b26f343d37f585 (diff)
FreeBSD 6.1 does not include wget by default. However, it has fetch which will
work just fine for our purposes of downloading the sounds packages. So, check for both wget and fetch and the configure script and use what was found to download them. If neither one was found, and sound packages are selected that must be downloaded, the install process will print out an informative error message indicating the situation. Also, fix a couple places where "make" was hard coded into some output messages by replacing them with the $(MAKE) variable. (issue #8451, initial patch by pabelanger, with additional modifications by me) git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@48190 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 881137cb5..e8ce5cc4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,6 +149,14 @@ AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
AC_PATH_PROG([DOT], [dot], :)
AC_PATH_PROG([STRIP], [strip], :)
+AC_PATH_PROG([WGET], [wget], :)
+if test "${WGET}" != ":" ; then
+ DOWNLOAD=${WGET}
+else
+ AC_PATH_PROG([FETCH], [fetch], [:])
+ DOWNLOAD=${FETCH}
+fi
+AC_SUBST(DOWNLOAD)
AC_LANG(C)