aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-09-14 15:50:49 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-09-14 15:50:49 +0000
commit70ba0ec26db55a30927a20513ff7958b92895035 (patch)
tree1038ba5510d7b25e122cbe93cc82ea534766f501 /configure.ac
parent4b7add369a1a77105a5f2738eb4e8c68be8b7c46 (diff)
Add checking for libusb here, so nobody has to deal with conflicts in the
chan_usbradio-1.4 branch every time the configure script gets changed git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@82385 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f44eabcdc..4eeab8597 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,7 @@ AST_EXT_LIB_SETUP([FREETDS], [FreeTDS], [tds])
AST_EXT_LIB_SETUP([TERMCAP], [Termcap], [termcap])
AST_EXT_LIB_SETUP([TINFO], [Term Info], [tinfo])
AST_EXT_LIB_SETUP([TONEZONE], [tonezone], [tonezone])
+AST_EXT_LIB_SETUP([USB], [usb], [usb])
AST_EXT_LIB_SETUP([VORBIS], [Vorbis], [vorbis])
AST_EXT_LIB_SETUP([VPB], [Voicetronix API], [vpb])
AST_EXT_LIB_SETUP([ZLIB], [zlib], [z])
@@ -980,6 +981,8 @@ fi
AST_EXT_LIB_CHECK([TONEZONE], [tonezone], [tone_zone_find], [zaptel/tonezone.h], [${tonezone_extra}])
+AST_EXT_LIB_CHECK([USB], [usb], [usb_init], [usb.h], [])
+
AST_EXT_LIB_CHECK([VORBIS], [vorbis], [vorbis_info_init], [vorbis/codec.h], [-lm -lvorbisenc])
AC_LANG_PUSH(C++)