aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2007-05-25 14:28:46 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2007-05-25 14:28:46 +0000
commit2638ef0c3bccf9d57cf28966bcfa43237af8a16e (patch)
tree53295335964d2cb94a3acf4fe3e6257fdb5b948d /configure.ac
parent6b8794ea03cf139278132b37c4f6889fcd142280 (diff)
handle the GNUTLS library properly in the configure script and build system
don't build in OSP support unless we have found and are allowed to use SSL support git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@66157 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c33724886..16693c473 100644
--- a/configure.ac
+++ b/configure.ac
@@ -422,10 +422,7 @@ fi
AST_EXT_LIB_CHECK([IKSEMEL], [iksemel], [iks_start_sasl], [iksemel.h])
if test "${PBX_IKSEMEL}" = 1; then
- AST_EXT_LIB_CHECK([GNUTLS], [gnutls], [gnutls_bye])
- if test "${PBX_GNUTLS}" = 1; then
- IKSEMEL_LIB="${IKSEMEL_LIB} -lgnutls -lz -lgcrypt -lgpg-error"
- fi
+ AST_EXT_LIB_CHECK([GNUTLS], [gnutls], [gnutls_bye], [gnutls/gnutls.h], [-lz -lgcrypt -lgpg-error])
fi
if test "${USE_IMAP_TK}" != "no"; then
@@ -697,7 +694,10 @@ AST_EXT_LIB_CHECK([UNIXODBC], [odbc], [SQLConnect], [sql.h], [-lltdl])
AST_EXT_LIB_CHECK([OGG], [ogg], [ogg_sync_init], [])
-AST_EXT_LIB_CHECK([OSPTK], [osptk], [OSPPCryptoDecrypt], [osp/osp.h], [-lcrypto -lssl])
+if test "$PBX_OPENSSL" = "1";
+then
+ AST_EXT_LIB_CHECK([OSPTK], [osptk], [OSPPCryptoDecrypt], [osp/osp.h], [-lcrypto -lssl])
+fi
if test "${USE_OSS}" != "no"; then
PBX_OSS=0