aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortzafrir <tzafrir@f38db490-d61c-443f-a65b-d21fe96a405b>2009-10-26 22:13:25 +0000
committertzafrir <tzafrir@f38db490-d61c-443f-a65b-d21fe96a405b>2009-10-26 22:13:25 +0000
commit8b0bc91966e7c3cc542933f6a40b2323fd1b0cc0 (patch)
tree2d3f591ef2661430be5a7046128f387fb16b0649 /configure.ac
parentd3c90b9f3120916f1bdeef7fc95cdf015fb49a30 (diff)
detect ARM Linux EABI OSARCH as linux-gnu instead of linux-gnueabi
* Set OSARCH to linux-gnu even if host_os is linux-gnueabi * When checking if we are Linux, check OSARCH rather than host_os The newer ARM ABI ("EABI") shows the OS name 'linux-gnueabi' rather than 'linux-gnu' . This patch sets OSARCH to be 'linux-gnu' even in such a case. OSARCH is tested for the value of 'linux-gnu' in one or two places in the tree. This patch also fixes the check libcap to check for $OSARCH rather than $host_os . See also: http://wiki.debian.org/ArmEabiPort git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@225957 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 46281d57b..c5c3f0c84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,6 +80,9 @@ case "${host_os}" in
solaris*)
OSARCH=SunOS
;;
+ linux-gnueabi)
+ OSARCH=linux-gnu
+ ;;
*)
OSARCH=${HOST_OS}
;;
@@ -494,7 +497,7 @@ AST_EXT_LIB_CHECK([ALSA], [asound], [snd_spcm_init], [alsa/asoundlib.h], [-lm -l
AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
-if test "x${host_os}" = "xlinux-gnu" ; then
+if test "x${OSARCH}" = "xlinux-gnu" ; then
AST_EXT_LIB_CHECK([CAP], [cap], [cap_from_text], [sys/capability.h])
fi