aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorqwell <qwell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-12-05 20:42:52 +0000
committerqwell <qwell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-12-05 20:42:52 +0000
commitfeafca5bb914d7694993e130c018d7a7310f2e3f (patch)
tree328f65460a7c762abe12a4155f23a8188df6d3e9 /configure.ac
parentcb4982e5713f6f5893ac284a1a2bb0bd8ed17b94 (diff)
Fix curl version number testing to be much more friendly to non-bash shells.
Issue 8508, patch by me. This *SHOULD* be POSIX compliant now.. git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@48279 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 7 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index e8ce5cc4c..409e376d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1033,22 +1033,13 @@ if test "${USE_CURL}" != "no"; then
AC_PATH_TOOL([CURL], [curl-config], No)
if test ! x"${CURL}" = xNo; then
# check for version
- if test "${host_os}" = "SunOS"; then
- if [[ 0x`curl-config --vernum` -ge 0x70907 ]]; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- else
- if [[[ 0x`curl-config --vernum` -ge 0x70907 ]]]; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- fi
- fi
+ if test $(printf "%d" 0x$(curl-config --vernum)) -ge $(printf "%d" 0x070907); then
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
+ fi
fi
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts channels/h323/Makefile])