aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-01 17:42:52 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-01 17:42:52 +0000
commitdec0a94ce31633c984850df74531bf4a2d09fd58 (patch)
tree7b73a49fa6879c4be994301069ac177b05a4978a /configure.ac
parentda1f08cd9a6b2d4f2c5957f1b2484e3c20d044ba (diff)
And for my last trick... make sure that if gethostbyname_r is exported by a library that it is used.
git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@77865 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a886ae627..bba577563 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,6 +262,8 @@ AC_FUNC_VPRINTF
AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent floor ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap pow putenv re_comp regcomp rint select setenv socket sqrt strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtol strtoq unsetenv utime vasprintf])
# some systems already have gethostbyname_r so we don't need to build ours in main/utils.c
+AC_SEARCH_LIBS(gethostbyname_r, [socket nsl])
+
AC_MSG_CHECKING(for gethostbyname_r with 6 arguments)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <netdb.h>],