aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-05-24 20:42:53 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-05-24 20:42:53 +0000
commita65f64b6b81f5f0981ef2cb12be164fac3de750f (patch)
tree597408babe528de1d6609b1f5a273571f4772a57 /configure.ac
parent946384dd4d6806e99e7f2e8df0c157dad707d705 (diff)
Checking for the strip application needs to be done with AC_PATH_TOOL
instead of AC_PATH_PROG to properly handle cross compilation environments. git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@66026 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8846c476e..ea8c14335 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,8 @@ AC_PROG_LN_S
AC_PROG_RANLIB
AST_CHECK_GNU_MAKE
+AC_PATH_TOOL([STRIP], [strip], :)
+
GNU_LD=0
if test "x$with_gnu_ld" = "xyes" ; then
GNU_LD=1
@@ -144,7 +146,6 @@ AC_PATH_PROG([DIRNAME], [dirname], :)
AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
AC_PATH_PROG([DOT], [dot], :)
-AC_PATH_PROG([STRIP], [strip], :)
AC_PATH_PROG([WGET], [wget], :)
if test "${WGET}" != ":" ; then
DOWNLOAD=${WGET}