aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-02-18 20:06:45 +0000
committerjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-02-18 20:06:45 +0000
commitc79298cc220361483baf3b9fe4352841352a3e92 (patch)
tree2edff152eaf12056d48c9405c05c9f356d17d4c2 /configure.ac
parentd7ae50ecdb4d2ef5988fdca4d2f075b95d06d9ce (diff)
Modify h323 to build against PTLib as well as the older PWLib
Several changes in PTLib have occurred requiring build time detection. Changes accounted for include the library name change, config option change, install location change, and a boolean type change which is handled by ast_ptlib.h. Also, the sed check has been modified to properly work with autoconf >= 2.62. (closes issue #14224) Reported by: bergolth Patches: asterisk-autoconf-sed.patch uploaded by bergolth (license 661) asterisk-pwlib-v3.patch uploaded by bergolth (license 661) Tested by: jpeeler git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@177160 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1db2519ec..ae7d0303a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1273,7 +1273,7 @@ if test "${USE_PWLIB}" != "no"; then
PWLIBDIR="${PWLIB_DIR}"
fi
AST_CHECK_PWLIB()
- AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2])
+ AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2], [P[[WT]]LIB_VERSION])
if test "${HAS_PWLIB:-unset}" != "unset"; then
AST_CHECK_PWLIB_PLATFORM()
@@ -1283,7 +1283,7 @@ if test "${USE_PWLIB}" != "no"; then
AST_CHECK_PWLIB_BUILD([PWLib], [PWLIB],
[Define if your system has the PWLib libraries.],
[#include "ptlib.h"],
- [BOOL q = PTime::IsDaylightSavings();])
+ [int q = (int) PTime::IsDaylightSavings();])
fi
fi